[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Subject Index][Author Index]

Re: My tyrannosaur hunter/scavenger paper online...



Works for me. I'm using Safari on a Mac if it matters.

That does matter. I'm using IE7 on Windows XP, and it doesn't work, probably because Windows doesn't cooperate that closely with Java. To install Mesquite http://mesquiteproject.org on another computer, I had to burrow through the website of Sun Microsystems, hunt down the latest version of Java, and install it -- all for free, but it took a long time all together. Looks like I have to repeat this exercise.


Here's what the Java console says:
-----------------------------------

Java(TM) Plug-in: Version 1.4.2
Usage of JRE Version 1.4.2 Classic VM
[...]

java.lang.UnsupportedClassVersionError: wordle/WordleApplet (Unsupported major.minor version 49.0)
at java.lang.ClassLoader.defineClass0(Native Method)
at java.lang.ClassLoader.defineClass(ClassLoader.java:800)
at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:147)
at java.net.URLClassLoader.defineClass(URLClassLoader.java:474)
at java.net.URLClassLoader.access$500(URLClassLoader.java:108)
at java.net.URLClassLoader$ClassFinder.run(URLClassLoader.java:846)
at java.security.AccessController.doPrivileged1(Native Method)
at java.security.AccessController.doPrivileged(AccessController.java:389)
at java.net.URLClassLoader.findClass(URLClassLoader.java:370)
at sun.applet.AppletClassLoader.findClass(AppletClassLoader.java:176)
at java.lang.ClassLoader.loadClass(ClassLoader.java:562)
at sun.applet.AppletClassLoader.loadClass(AppletClassLoader.java:156)
at java.lang.ClassLoader.loadClass(ClassLoader.java:494)
at sun.applet.AppletClassLoader.loadCode(AppletClassLoader.java:594)
at sun.applet.AppletPanel.createApplet(AppletPanel.java:675)
at sun.plugin.AppletViewer.createApplet(AppletViewer.java:1875)
at sun.applet.AppletPanel.runLoader(AppletPanel.java:604)
at sun.applet.AppletPanel.run(AppletPanel.java:333)
at java.lang.Thread.run(Thread.java:568)


------------------------------------------
Looks like having the pretty recent Java 1.4.2 is not enough.